TITLE:
Error "Error 1053: The service did not respond to the start or
control request in a timely fashion" for AMP sensor service and
WebInspect scheduler service
ISSUE:
Your Assessment Management Platform (AMP®) 3.x sensor service,
WebInspect™ scheduler service, or some other SPI-related service fails
with an error message similar to the following.
"Error 1053: The service did not respond to the start or control request in a timely fashion"
CAUSE:
This issue appears to be related to a known Microsoft issue in
which a service may not start before a defined timeout. The issue is
more likely to occur if your computer is heavily loaded, or if the
installation is within a VMware image, resulting in generally slower
performance.
SOLUTION:
Increase the timeout value for service startup process to give it
more time to load when the computer (or VMware image) starts. To do so,
use the following procedure.
1. Click Start, click Run, type regedit, and then click OK.
2. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
3. Right-click Control, point to New, and then click DWORD Value.
4. In the New Value #1 box, type ServicesPipeTimeout, and then press ENTER.
5. Right-click ServicesPipeTimeout, and then click Modify.
6. Click Decimal, type the number of milliseconds that you want to
wait until the service times out, and then click OK. Typically, a data
value of 35,000 is sufficient to keep the service from timing out.
However, you can reduce or increase this value according to your
specific startup requirements. For example, to wait 60 seconds before
the service times out, type 60000.
7. Quit Registry Editor, and then restart the computer.
APPLIES TO:
AMP 3.x
WebInspect 7.x
MORE INFORMATION:
See complete details on the Microsoft issue at the following knowledge base article:
http://support.microsoft.com/?kbid=884495
See additional details for events 7000 and 7011 on Windows 2003 at the following knowledge base article:
http://support.microsoft.com/kb/922918/en-us